SCM(ServiceControlManager)が、タイムアウトしてUnifierサービスが起動できません。対策があれば教えてください

Windowsで指定されているタイムアウト値を変更するためにレジストリを編集します。

対象バージョン

すべてのバージョン



現象

Unifierクライアントの電源起動時に、Unifier サービス(Flex Work Place Unifier System Service)の起動が失敗する現象がまれに報告されています。



原因

Unifierクライアントのハードウエアスペックが低い場合やサービスが大量にインストールされていると、Windowsで指定されている時間内(既定:30秒)にサービスを起動できずにタイムアウトを起こしてしまうためです。



解決策

Windowsで指定されているタイムアウト値を変更するために、レジストリを編集します。


【編集対象レジストリ】
キー HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
エントリ ServicesPipeTimeout
種類 REG_DWORD
データ 30000 (既定値)  ※単位はミリ秒、30000 = 30 秒


【編集手順】
No. 手順
1
[スタート]ボタンをクリックし、[ファイル名を指定して実行]をクリックします。
2
名前欄に[regedit]と入力して、 [OK]をクリックします。
3
上表のレジストリキーを開きます。
4
Control を右クリックし、右クリックから[新規作成]をポイントして、[DWORD 値]をクリックします。
5
[New Value #1]ボックスで[ServicesPipeTimeout]と入力し、[Enter]キーを押します。
6
Decimal(10進数) のラジオボタンを選択し、サービスがタイムアウトするまで待つ時間をミリ秒単位で入力し、 [OK] をクリックします。
例えば、サービスがタイムアウトするまで「60秒」待機させるには「60000」を入力します。
7
レジストリエディターを終了します。
8
コンピュータを再起動します。


Microsoft社のホームページにも同様の手順が公開されております。そちらもあわせてご参照ください。
https://support.microsoft.com/ja-jp/help/839803/the-windows-trace-session-manager-service-does-not-start-and-event-id


その他のよくあるご質問

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